viernes, 10 de octubre de 2014

Windows 10 y Powershell 5.0

Después de instalar WINDOWS 10 en virtual box, maquina virtual, gratuita y de código abierto.

Como buen entusiasta de las novedades de Windows empece a trastear a ver que habían cambiado que me sirve en mi día a día:

PowerShell,
La primera novedad, la manera de ejecutar, aparece en la pantalla de menú y nos permite ejecutarlo en modo ise directamente.  (10 razones para usar PowerShell Ise en lugar de PowerShell) enlace en ingles

Trasteando un poco ejecutamos Get-Host para averiguar que versión esta instalada
















¡Sorpresa! trae instalado powershell 5.0,

Es una versión todavía previa no esta finalizada, pero ya nos permite ver que cmdlets han añadido, recordar que de la versión 1 a la 2 pasaron de 240 a 2700 cmdlets, decir también que es compatible con todo lo que teníamos programado y que en próximas entradas se comentaran mas novedades.

Si lo queremos instalar en nuestro server 2012 o nuestro windows 8.1 deberemos instalarlo desde aquí
http://www.microsoft.com/en-us/download/details.aspx?id=44070

martes, 7 de octubre de 2014

Solucion al error 0x0000007B equipo no arranca o reinicia constantemente

Este error es típico en los equipos antiguos, viene a decirnos que el disco de arranque o la parte del boot, no es la que se espera o no existe.

Para equipos antiguos, equipos con BIOS, se solia solucionar, desinstalando el driver de los discos, o creando de nuevo el MBR, ya que se nos podria haber metido un virus en esos sectores necesarios del arranque, para estas soluciones esta internet lleno de tutoriales paso a paso.

Ahora bien,la solución para equipos nuevos aunque muy fácil no la encontraras por Internet, si tienes un equipo moderno, sabrás que ya no tienen BIOS ahora se van sustituyendo por las flamante UEFI ¿Que es UEFI? y no es de las pocas cosas que habrán cambiado en tu ordenador, tus discos sata, ahora tienen la capacidad de trabajar en modo AHCI. bastante superior y si tu equipo lo has comprado ensamblado con el software instalado ten por seguro que lo habrán configurado en modo UEFI.

Problema: Posiblemente se haya desconfigurado la UEFI (recuerda la nueva BIOS) y al cargar las opciones por defecto (Load setup defaults), haya cambiado como tratar el disco duro, poniendo la opción mas antigua en teoría mas compatible, con lo que se habrá cambiado de AHCI a IDE

Solución:Al arrancar Entra en la UEFI (nueva bios), busca una opción parecida o igual a SATA Mode Select: y ponlo en AHCI , guarda cambios y ya lo tienes.